# Netconf delete operation

**URL:** <https://dmap-community.ductus.global/t/netconf-delete-operation/1520>\
**Category:** NETCONF\
**Created:** [September 8, 2017, 7:08am UTC](https://dmap-community.ductus.global/t/netconf-delete-operation/1520 "2017-09-08T07:08:46Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Hatim5253](https://avatars.discourse-cdn.com/v4/letter/h/7993a0/32.png) [@Hatim5253](https://dmap-community.ductus.global/u/Hatim5253)\
**Post date:** [September 8, 2017, 7:08am UTC](https://dmap-community.ductus.global/t/netconf-delete-operation/1520/1 "2017-09-08T07:08:46Z")

</div>

hello,

I have configured ISIS, LDP on my router.  
now, I want all the configuration on my router to be deleted using “delete-config” operation.

Can you please suggest how i do it??  
As per RFC 6247, I cannot use “delete-config” on running datastore

---

<div class="post-metadata">

**Author:** ![mnovak](https://yyz2.discourse-cdn.com/flex010/user_avatar/dmap-community.ductus.global/mnovak/32/183_2.png) [@mnovak](https://dmap-community.ductus.global/u/mnovak)\
**Post date:** [September 8, 2017, 8:11am UTC](https://dmap-community.ductus.global/t/netconf-delete-operation/1520/2 "2017-09-08T08:11:41Z")

</div>

Did you try to use `<edit-config>` with attribute `operation=delete`?

See [https://tools.ietf.org/html/rfc6241#page-37](https://tools.ietf.org/html/rfc6241#page-37) (delete examples)

---

<div class="post-metadata">

**Author:** ![Hatim5253](https://avatars.discourse-cdn.com/v4/letter/h/7993a0/32.png) [@Hatim5253](https://dmap-community.ductus.global/u/Hatim5253)\
**Post date:** [September 18, 2017, 10:58am UTC](https://dmap-community.ductus.global/t/netconf-delete-operation/1520/3 "2017-09-18T10:58:26Z")

</div>

“Edit-config” with delete operation will delete a particular parameter.  
My intention is to delete the complete config. Is it still possible via edit-config?

---

<div class="post-metadata">

**Author:** ![cohult](https://yyz2.discourse-cdn.com/flex010/user_avatar/dmap-community.ductus.global/cohult/32/221_2.png) [@cohult](https://dmap-community.ductus.global/u/cohult)\
**Post date:** [September 18, 2017, 1:00pm UTC](https://dmap-community.ductus.global/t/netconf-delete-operation/1520/4 "2017-09-18T13:00:14Z")

</div>

> “Edit-config” with delete operation will delete a particular parameter.

`<edit-config>` will delete the configuration under the element that contain the delete or remove operation.  
Note that in the example on [page 41 in RFC6241](https://tools.ietf.org/html/rfc6241#page-41) a list entry with a specific key is deleted, so all data in the list entry is deleted too.

For deleting the all of the configuration, see [RFC 6241 - Network Configuration Protocol (NETCONF)](https://tools.ietf.org/html/rfc6241#section-7.4) for an example.

---

<div class="post-metadata">

**Author:** ![cohult](https://yyz2.discourse-cdn.com/flex010/user_avatar/dmap-community.ductus.global/cohult/32/221_2.png) [@cohult](https://dmap-community.ductus.global/u/cohult)\
**Post date:** [September 18, 2017, 4:10pm UTC](https://dmap-community.ductus.global/t/netconf-delete-operation/1520/5 "2017-09-18T16:10:41Z")

</div>

From the ConfD UG Chapter 15 “The NETCONF Server”:

`For the <delete-config> operation specified in RFC 4741 / RFC 6241, only <url> with scheme "file" is supported for the <target> parameter - i.e. no data stores can be deleted. The concept of deleting a data store is not well defined, and at odds with the transaction-based configuration management of ConfD. To delete the entire contents of a data store, with full transactional support, a <copy-config> with an empty <config/> element for the <source> parameter can be used.`
